当前位置:米豆网 jQuery

jQuery UI 1.9.0及jQuery Mobile 1.2.0稳定版发布

2012年10月19日 | 作者: 米豆网 - 1000seo |

jQuery UI和jQuery Mobile团队宣布发布新的稳定版本的jQuery UI和jQuery Mobile,其中包括了新的特性,API重新进行了设计以及其他改进和bug修复。 在经过了一系列的里程碑版本,beta和RC版本的发布后,jQuery UI团队宣布发布稳定版本1.9.0,其中包含了新的widgets,对API进行了重新设计以及bug修复。新的wigets包括: Menu——自1.8版本开始,菜单是autocomplete widget的一部分;现在已经成为独立的UI组件。 Spinner——除了常规的功能外,现在Spi......
关键词:, ,
详细阅读

jQuery $(this).attr(‘checked’)出现undefined的问题

2012年07月16日 | 作者: 米豆网 - 1000seo |

最近在对一个项目的前端进行调整时,发现项目原来用的低版本的jQuery存在一些问题,于是就把jQuery换成了比较新的v1.72,但是发现原来$(this).attr(‘checked’)返回的不再是true or false,选中的情况下返回checked,未选中的情况返回undefined,看了jQuery文档后原来v1.6以后$(this).attr(‘checked’)就返回checked和undefined,v1.6以前返回true和false,v1.6以后可以使用$(this).is(‘:checked’)或者$(this).prop(&#......
关键词:, ,
详细阅读
+2°

jQuery 2.0将不再支持IE 6/7/8相关特性

2012年07月12日 | 作者: 米豆网 - 1000seo |

jQuery官方发布了下一阶段jQuery的路线图,该路线图显示jQuery 1.8将在一个月内发布,而其他后续版本的计划如下:   jQuery 1.9:将在2013年初发布,该版本将移除许多在1.8中不建议使用的API,其中一些将作为插件或备选API。该版本仍将支持IE 6/7/8。 jQuery 1.9.x:为1.9正式版发布后的修复版本,主要修复发现的bug等。 jQuery 2.0:将在2013年初,1.9版本之后不久就会发布,该版本将延续1.9版本所支持的API,但会移除对IE 6/7/8中的相关......
关键词:, ,
详细阅读

javascript跨浏览器添加事件绑定

2012年07月06日 | 作者: 米豆网 - 1000seo |

IE 的事件绑定函数是 attachEvent;而 Firefox, Safari 是 addEventListener;Opera 则两种都支持。使用jQuery就可以使用简单的bind(),或者$().click()之类的函数解决,而如果不使用JavaScript框架的时候,大家可是使用下面的封装bind()函数。 /************************************ * 添加事件绑定 * @param obj : 要绑定事件的元素 * @param type : 事件名称。不加 “on”. 如 : “click” 而不是 “onclick&#......
关键词:, , , , ,
详细阅读